Home > Error Cannot > Error Cannot Link With The Boost Thread Library

Error Cannot Link With The Boost Thread Library

DomT4 closed this Jan 6, 2016 MikeMcQuaid locked and limited conversation to collaborators Jul 10, 2016 Sign up for free to subscribe to this conversation on GitHub. yes checking for joinable pthread attribute... Does anyone on this thread know how to access the ./configure script used by Homebrew? Creating data directories... /usr/bin/install -c -m 644 povray.conf '/usr/local/Cellar/povray/3.7.0.0_1/etc/povray/3.7' /bin/sh: -c: line 0: unexpected EOF while looking for matching `"' /bin/sh: -c: line 1: syntax error: unexpected end of file make[2]: this contact form

yes checking for boost/program_options.hpp... Quote Postby d.j.a.y » Sun Apr 06, 2014 6:00 am first i think that you should follow those instructions in order to setup the build : viewtopic.php?f=13&t=972and also have a look Not the answer you're looking for? yes checking for exit in -lboost_thread...

I also had to add "-lrt" to src/Makefile in CXXFLAGS Then, running make produced the correct binaries. no > configure: error: Could not link against boost_thread-boost_thread ! > > > Any suggestion on 'boost_thread-boost-thread'? > > Thanks again! > Wise > > Post a reply to this message What security operations provide confidentiality, integrity and authentication? The --with-boost option is wrong, should be --with-boost=/data/xma/local/boost/include/boost/.   Hope this post helps in case anyone else meet the same problem.

  • If you have this permission on the directory and on the boost lib, linking with gcc can be done : g++ obj.o obj2.o -L/usr/lib -lboost_thread if you don't own files or
  • yes > > checking whether the Boost::Thread library is available...
  • If it only work as root, check your privilege in this directory : ls -la /usr/lib/ | grep boost you should see your login, and rw_r_r_ (check you have the read
  • no > checking for exit in -lboost_thread-boost_thread...

Just update the boost lib like this: sudo apt-get install mpi-default-bin mpi-default-dev libboost-all-dev povray good luck rohgeo (rohgeo) wrote on 2012-05-27: #4 my os is centos 6.2 ./configure --prefix=/usr/local/gearmand --with-boost=/usr/local/boost boost My email address is wis###[at]intelcom Thank you very much! The output from the terminal, and config.log are located here: https://gist.github.com/j6thomps/602147d1c016fa2fa349. Top og_da_trog Posts: 18 Joined: Fri Apr 04, 2014 7:36 pm Re: error: Could not link against boost_program_options !

yes checking whether the boost thread library is usable... no > checking for the pthreads library -llthread... yes > checking whether the Boost::Thread library is available... https://github.com/Homebrew/legacy-homebrew/issues/45317 Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 1,053 Star 29,480 Fork 14,002 Homebrew/legacy-homebrew Code Issues 1 Pull requests 0 Projects

Do Morpheus and his crew kill potential Ones? no checking for the pthreads library -lpthreads... Top d.j.a.y Site Admin Posts: 1355 Joined: Fri Apr 27, 2012 4:35 am Contact: Contact d.j.a.y Website Re: error: Could not link against boost_program_options ! Don't forget to specify the path to boost directory with -L/usr/lib/boost.

tophat • 1.8k views ADD COMMENT • link • Not following Follow via messages Follow via email Do not follow modified 10 months ago by mmfansler • 10 • written 23 http://news.povray.org/povray.unix/thread/%[email protected]%3E/ Post a reply to this message Synfig Project Forum Forums for Synfig Project Skip to content Search Advanced search Quick links Unanswered topics Active topics Search The team FAQ Login Register I tried the > --with-boost-thread=boost_thread-mt flag suggested on the download page, > but it didn't help. > > Any suggestions? gcc44 -gcc checking boost/program_options.hpp usability...

Problem Compiling Tophat: Boostlib >= 1.38.0 Not Found [[email protected] tophat-2.0.9]# ./configure --prefix=/usr/local/bin/ checking for a BSD-compatible i... (Mira) Configure: Error: Could Not Find A Version Of The Library! (Boost::Thread Library) checking weblink I do not have ... sudo apt-get install libboost-all-dev Now I can locate them as below: /usr/lib/x86_64-linux-gnu/libboost_date_time.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_iostreams.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_program_options.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_python-py27.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_python-py33.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.53.0 /usr/lib/x86_64-linux-gnu/libboost_thread.so.1.53.0 And I tried to run the configure again, and the error message is I've tried running ./configure with both options (-mt and not -mt for boost_system) in the LIB variable, but I get the same error.

share|improve this answer answered Feb 12 '14 at 22:31 Klaus Warzecha 1,540917 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google So i downloaded the boost source, compiled, and installed in /usr/local. no > checking whether to build the boost thread library from sources... navigate here There seem to be problems with unmatched double quotes though, in both ./configure line 15723 (and following) as well as later in some unidentified file during make.

Any suggestion on 'boost_thread-boost-thread'? DomT4 commented Oct 31, 2015 It's possible the Boost detection logic in the formula itself is having some issues, I guess. no > checking whether pthreads work with -kthread...

Content Search Users Tags Badges Help About FAQ Access RSS Stats API Use of this site constitutes acceptance of our User Agreement and Privacy Policy.

Peter Valdemar Mørch (pmorch) wrote on 2015-02-12: #7 Make that LDFLAGS=-lboost_system to also let it pass 'make' also :-) I also needed apt-get install libpq-dev and CPPFLAGS="-I/usr/include/postgresql" here on Debian jessie, yes checking boost/program_options.hpp presence... Bill P. how to resolve , configure: error: Stopping here as BOOST thread lib must be available at this stage.

no checking whether pthreads work with -pthread... Can there be a sarcastic meaning to "top gun" in a (non-)linguistic context like this? asked 2 years ago viewed 2623 times active 17 days ago Related 1POV-Ray - Ubuntu 12.04 file not found1Can boost 1.54 install with libboost_thread-mt.so like library files using apt-get install libboost-all-dev http://optimisersonpc.com/error-cannot/error-cannot-initialize-hook-library.html Quote Postby og_da_trog » Mon Apr 07, 2014 8:41 pm okay, thankyou that fixed that problem, except now I get the error:config.status: config.h is unchangedconfig.status: executing depfiles commandsconfig.status: executing libtool commandsconfig.status:

I'd recommend to always use the pre-compiled binaries. no checking whether pthreads work with -pthread... Powered by Biostar version 2.3.0 Traffic: 1387 users visited in the last hour I get an error during linking, this is the message: /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lboost-thread But it's strange because this happens only when I compile with a normal user, using root I

Until then, you may try explicitly requesting the use of clang, by passing CC=clang and CXX=clang to the ./configure script. no checking whether to build the boost thread library from sources... no > checking whether pthreads work with -kthread... Then I got to where I had to type inCode: Select all./configurefor synfig-core (at this point I'd already typed './configure' in once for ETL, it worked fine then.)it gave me this:checking

Can anybody tell me how to specify this correctly? Though it never occurred to me that other users might have the same trouble figuring this out - after all, if it isn't explicitly mentioned *anywhere*, it just *must* be trivial We recommend upgrading to the latest Safari, Google Chrome, or Firefox. no configure: error: in /Users/j6thomps/Downloads/povray-3.7-stable':
configure: error: cannot link with the boost thread library
Seeconfig.log' for more details So it would seem that homebrew is getting further in the installation process,

See full activity log To post a comment you must log in. c-lipka commented Oct 28, 2015 I consider it a bad move from Apple to disguise a different C/C++ compiler as GCC in the first place (which is what they seem to in other words i... The proper solution would be to fix the compiler detection in autoconf/automake (or Homebrew's fork thereof) so that it defaults to clang on Mac OS X.

It is available in synfig/autobuild. If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. Affecting: Gearman Filed here by: rohgeo When: 2012-05-15 Completed: 2012-11-01 Target Distribution Baltix BOSS Juju Charms Collection Elbuntu Guadalinex Guadalinex Edu Kiwi Linux nUbuntu PLD Linux Tilix tuXlab Ubuntu Ubuntu Linaro yes > checking for joinable pthread attribute...

no configure: error: in `/home/rakshasa/Downloads/tmp/povray-3.7.0.RC7': configure: error: cannot link with the boost thread library See `config.log' for more details config.log had the following to say: configure: failed program was: | /* no > checking whether pthreads work with -pthread... Terms Privacy Security Status Help You can't perform that action at this time.

Back to Top